
Color y textura
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¿Qué es el color?
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[Goethe, 1810]

“El color es producto de la luz a ciertas 
longitudes de onda”

“El color es producto de la percepción 
del observador”

[Newton, 1686]



Proceso de visión
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Proceso de visión
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Spectrum Power Distribution (SPD)
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El color no existe por si mismo

• Pero… 

• Igual SPD producen diferentes colores percibidos. 

• Iguales colores percibidos provienen de diferentes SPD. 

• Color appearance is strongly affected by other nearby colors, by adaptation to 

previous views, and by “state of mind”.
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Hermann von Helmholtz Ewald Hering

“El color se percibe como la 
combinación de tres colores 

primarios.”

“El color se percibe como la 
combinación de tres parejas de 

colores opuestos.”

(rojo, verde y azul) (rojo-verde, blanco-negro y azul-amarillo)

“Controversia 
Helmhotz-Hering”  

… y los dos tenían razón.



¿Son de igual color los cuadrados pequeños?



¿Son de igual color los cuadrados pequeños?



¿Son de igual color los cuadrados A y B?



¿Son de igual color los cuadrados A y B?



[FIJI: File > Open Samples > Striped Circles]

¿De qué color son los círculos?



[FIJI: File > Open Samples > Striped Circles]

¿De qué color son los círculos?



Sistema Visual Humano: El ojo
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Sistema Visual Humano: Fotoreceptores
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[Adaptado de https://upload.wikimedia.org/wikipedia/commons/c/c0/Eyesensitivity.svg]

https://upload.wikimedia.org/wikipedia/commons/9/94/1416_Color_Sensitivity.jpg

Mustafi, D., Engel, A. H., & Palczewski, K. (2009). Structure of cone photoreceptors. 

Progress in retinal and eye research, 28(4), 289-302.



Sistema Visual Humano: La retina
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Distribución de conos y bastones en la retina

Mustafi, D., Engel, A. H., & Palczewski, K. (2009). Structure of cone photoreceptors. 

Progress in retinal and eye research, 28(4), 289-302.



Enfocar el ojo izquierdo en la cruz, taparse el ojo derecho y colocarse a unos 
30 cm de la imagen, hasta que “desaparece” el punto.



Representación del color
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Experimentos de Wright (1928) y Guild (1931).



Representación del color

• El color es una característica de tres dimensiones. 

• Muchos colores pueden representarse como la mezcla de tres “colores primarios” A, 

B y C. 

• Adición: 

• Principio de tricromacia (tristimulus): con tres colores primarios se pueden generar 

otros colores (para la mayoría de las personas). 

• En general un espacio de representación de color está generalmente asociado con un 

hardware (displays, impresoras, …)
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D = waA+ wbB + wcC

D + waA = wbB + wcC ⇒ D = −waA+ wbB + wcC

RGB (aditivo, luz) CMY(K) (sustractivo, pigmentos)



RGB

• Aditivo 

• Suma de tres luces sobre un papel. 

• Muy simple. Usado en computadoras, monitores, cámaras, scanners, teléfonos, … 

• Calibración para colorimetría. 

• No es ajustado para operaciones con colores (p.e. promedio colores).
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R
R75

R50
R25

PK

RGB Value

Point Color R G B

S Black 0.00 0.00 0.00

R Red 1.00 0.00 0.00

Y Yellow 1.00 1.00 0.00

G Green 0.00 1.00 0.00

C Cyan 0.00 1.00 1.00

B Blue 0.00 0.00 1.00

M Magenta 1.00 0.00 1.00

W White 1.00 1.00 1.00

K 50% Gray 0.50 0.50 0.50

R75 75% Red 0.75 0.00 0.00

R50 50% Red 0.50 0.00 0.00

R25 25% Red 0.25 0.00 0.00

P Pink 1.00 0.50 0.50
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K = min(C,M, Y )
<latexit sha1_base64="Tg6XdOcuhUTs//YqRtDGBdQgm0Y="></latexit>

C = (C −K)/(1−K)
M = (M −K)/(1−K)
Y = (Y −K)/(1−K)

RGB a CMY:

CMY a CMYK:
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RGB

[FIJI: Plugins > Color Inspector 3D]



[FIJI: Plugins > Color Inspector 3D]



Tipos de imágenes RGB
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3 component arrays
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Representación de RGB
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#9a2069 = (9a,20,69) Hexadecimal 
(154,32,105) 

(0.6,0.12, 0.41)

[Image > Color > Color Picker] (ctrl + shift + K)



• Espacio de color CIE XYZ 

• Colores primarios imaginarios: X (red), Y (green), Z (blue). Y es la luminancia percibida. 

• Basado en experimentos de percepción visual humana (tristimulus).

CIE XYZ colores primarios imaginarios. 

C.I.E. 1931 Color Space
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x+ y + z = 1



C.I.E. 1931 Color Space

20

X

Y

Z

0

1

1

1

G

B

C

M

Y

S

W

E

A = (Xa, Ya, Za)

a

!"# $%

!&# $%

!'# $%

&## $%

&'#((()'# $%

*'# $%

"'# $%

!## $%

#(!

+(#

#(#

#(# #(! +(#

!,# $%

R

G

B

C

M

Y

E

x

y

X

Y

Z

0

1

1

1

x

y

Chromaticity Diagram 

(Proyección al plano xy)



C.I.E. 1931 Color Space
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Chromaticity Diagram



C.I.E. 1931 Color Space
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Chromaticity Diagram



C.I.E. 1931 Color Space
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Chromaticity Diagram



C.I.E. 1931 Color Space
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Chromaticity Diagram



C.I.E. 1931 Color Space
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¿De qué color son?
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Tono (Hue)
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¿De qué color son?
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“Más verde”

“Menos verde” 



Saturación
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“Pureza” del color; “mezcla con blanco”.



¿De qué color son?
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Más saturado

Menos saturado



Mismo tono, diferente saturación
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100% 90% 80% 70%

60% 50% 40% 30%

20% 10% 0%



Más claro

¿De qué color son?

29

Más oscuro

Mismo tono, misma saturación, ¿qué es diferente?

Brillo, intensidad, …



• RGB ⟷ HSB, HSV, HSI 

• Son muy usados en edición gráfica para la elección de colores. 

• Más eficientes que RGB/CMYK para seleccionar colores 

similares por tono y saturación. 

• No lineal

HSV, HSI, HSB
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R25

P

RGB/HSV Values

Pt. Color R G B H S V

S Black 0.00 0.00 0.00 — 0.00 0.00

R Red 1.00 0.00 0.00 0 1.00 1.00

Y Yellow 1.00 1.00 0.00 1/6 1.00 1.00

G Green 0.00 1.00 0.00 2/6 1.00 1.00

C Cyan 0.00 1.00 1.00 3/6 1.00 1.00

B Blue 0.00 0.00 1.00 4/6 1.00 1.00

M Magenta 1.00 0.00 1.00 5/6 1.00 1.00

W White 1.00 1.00 1.00 — 0.00 1.00

R75 75% Red 0.75 0.00 0.00 0 1.00 0.75

R50 50% Red 0.50 0.00 0.00 0 1.00 0.50

R25 25% Red 0.25 0.00 0.00 0 1.00 0.25

P Pink 1.00 0.50 0.50 0 0.5 1.00
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Conversión a escala de grises

• Imagen con el “equivalente” en grises o la “luminancia” Y.  

• No hay una única forma 

• La más simple  

• La percepción de los canales no es la misma 

• Promedios ponderados
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Y =
R+G+B

3

Y = wRR+ wGG+ wBB

wR = 0.299 , wG = 0.587 , wB = 0.114 .

wR = 0.2125 , wG = 0.7154 , wB = 0.072 .

8 bits Lab RGB LuminanceOriginal RGB R+G+B

3



CIE L*a*b*

• Basado en un conjunto de colores base (imaginarios) CIE XYZ creados en 1931. 

• Uniformidad cercana a la percepción visual humana. 

• La distancia Euclidea entre dos colores es similar a la diferencia percibida entre 

ellos.  

• Independientes del dispositivo de despliegue. 

• Desacopla la intensidad del color  

• L* corresponde a la luminosidad 

• a* corresponde a la variación de tono-saturación en el eje verde-rojo, y b* en el eje azul-

amarillo.
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XW , YW , ZW son valores de referencia relacionados con el blanco en el estándar CIE D65.
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Evolución de la representación del color

• Primera generación: colores físicos 

• RGB, XYZ, … 

• Segunda generación: psicovisión 

• CIE Lab, Munsell, … 

• Tercera generación: apariencia espacial del color 

• CAM, Retinex, ACE, …

36

Image> Color> Retinex
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Image> Color> Retinex



Cuantización de colores
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Original (24 bits) 256 colores (8 bits)

2 colores (1 bit)8 colores (3 bits)



Pseudo-color

• Uso de un mapa de colores para la visualización de imágenes monocromáticas. 

• Mejor discernimiento de colores.

39



Color segmentation

• “Color Segmentation: ImageJ plugin to cluster color pixel driven by the user input” 

• Bajar e instalar ColorSegmentation_.jar* 

• Abrir la imagen mandas.jpg 

• Con la herramienta POINTCROSS elegir los colores (A, B, C, …). Se pueden seleccionar 
más de un punto por color. 

• Elegir Clustering Method 

• Elegir algoritmo: K-Means (faster one) or Hidden Markov Model (agrega restricciones 
espaciales). 

• Run

40

* Daniel Sage 

  EPFL Biomedical Imaging Group 

  http://bigwww.epfl.ch/sage/soft/colorsegmentation/

http://bigwww.epfl.ch/sage/soft/colorsegmentation/


Textura

41



¿Qué es la textura?



¿Qué es la textura?

• Concepto alto nivel. 

• Suavidad, áspero, regularidad, patrón repetitivo, … 

• No local. 

• No hay una medida trivial, objetiva. 

• Análisis basado en descriptores o características (features). 

• Estructural: primitivas de construcción de la imagen 

• Estadístico: suave, granular, … 

• Espectral: periodicidad, potencia en el espectro.
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Dependencia con la escala
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Dependencia con la escala

45
Testículos ovinos (hematoxilina-eosina) 4x



Dependencia con la escala
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Testículos ovinos (hematoxilina-eosina) 10x



Dependencia con la escala
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Testículos ovinos (hematoxilina-eosina) 40x



Aplicaciones

• Clasificación: determinar el tipo (clase) a una nueva muestra 
• Segmentación: partir en regiones de textura similar 
• Síntesis: dada una muestra, generar otras de apariencia similar 
• Recuperación de pose y estructura: shape from texture

48
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• Momentos estadísticos del histograma de intensidades. 

• Primeros dos momentos 

• Segundo momento (varianza)                   o desviación estándar  

• Medida del contraste y la suavidad de la variación. 

• Tercer momento (skewness)       es una medida de la simetría del histograma 

• Cuarto momento (flatness) es una medida de la “llanura”.

Métricas estadísticas

p(zi)
µn(zi) =

L−1X

i=0

(zi −m)np(zi)

m =

L−1X

i=0

zip(zi)

0 1 L - 1

R = 0

R → 1

zonas constantes

zonas mucha variación.

µ0 = 1, µ1 = 0

µ2 = σ
2(zi)X

R = 1−
1

1 + σ
2(z)

σ(z)

µ3



50

• “Uniformidad”  

• Entropía 

• R (normalizada)

Métricas estadísticas

U(z) =
L−1X

i=0

p2(zi)X

e(z) = −

L−1X

i=0

p(zi) log2 p(zi)

<latexit sha1_base64="tGZv3ZQI2xB/2hErU9EWQk35I+I="></latexit>
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1

1 + σ
2(z)



Métricas estadísticas
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Smooth 82.64 11.79 0.002 0.026 5.434

Coarse 143.56 74.63 0.079 0.005 7.783

Regular 99.72 33.73 0.017 0.750 0.013 6.674

-0.151

-0.105
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Métricas estadísticas

• Los histogramas no tiene información de la posición de las intensidades, que es un 

aspecto clave para la textura. 

• Matriz de co-ocurrencia

52
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Métricas estadísticas
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DescriptorNormalized

Co-occurrence Max 

Matrix Probability Correlation Contrast Uniformity Homogeneity Entropy

0.00006 10838 0.00002 0.0366 15.75

0.01500 0.9650 570 0.01230 0.0824 6.43

0.06860 0.8798 1356 0.00480 0.2048 13.58G3>n3

G2>n2

-0.0005G1>n1

1 2 3
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Métricas espectrales

• Con la TF se detectan: 

• Picos dominantes asociados a 

direcciones principales de textura. 

• Tamaño (frecuencia) de las 

repeticiones espaciales. 

• Eliminando (filtrando) esas 

componentes dominantes queda la 

información no periódica que puede 

describirse con métricas estadísticas.
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• Basadas en la Transformada de Fourier o variantes como la DCT. 

• Ajustada para distinguir patrones repetitivos o periódicos. 

• Patrones globales.



Métricas basadas en filtros

• Representan la imagen a partir de la respuesta a un conjunto de filtros

55



Métricas basadas en filtros

• Representan la imagen a partir de la respuesta a un conjunto de filtros
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Conjunto de filtro de Gabor 

de diferente orientación y 

escala.



Métricas basadas en filtros
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Descriptores

• Las diferentes medidas, estadísticas, filtrados (procesamiento en general) nos 

permite obtener descriptores de una ROI, objeto, imagen, eventos, trayectoria, … 

• Con estos descriptores es posibles aprender a diferenciar los casos de interés.
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Pattern Recognition / Machine Learning
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Tasks (2014-09-24)  
https://xkcd.com/1425

https://xkcd.com/1425
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Referencias

• Digital Image Processing, An Algorithm Introduction to Java. Wilhelm Burger & 

Mark J. Burge. Springer, ISBN 978-1-84628-379-6  

• Las trasparencias usan material del libro disponible en http://www.imagingbook.com/ 

• Digital Image Processing, Gonzalez & Woods.  

• Las trasparencias usan material del libro http://www.imageprocessingplace.com/
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