
Color y textura
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ÀQuŽ es el color?
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[Goethe, 1810]

ÒEl color es producto de la luz a ciertas 
longitudes de ondaÓ

ÒEl color es producto de la percepci—n 
del observadorÓ

[Newton, 1686]



Proceso de visi—n

3



Proceso de visi—n
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Spectrum Power Distribution (SPD)
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Spectrum Power Distribution (SPD)



El color no existe por si mismo

¥ PeroÉ 

¥ Igual SPD producen diferentes colores percibidos. 

¥ Iguales colores percibidos provienen de diferentes SPD. 

¥ Color appearance is strongly a! ected by other nearby colors, by adaptation to 
previous views, and by Òstate of mindÓ.
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Hermann von Helmholtz Ewald Hering

ÒEl color se percibe como la 
combinaci—n de tres colores 

primarios.Ó

ÒEl color se percibe como la 
combinaci—n de tres parejas de 

colores opuestos.Ó
(rojo, verde y azul) (rojo-verde, blanco-negro y azul-amarillo)

ÒControversia 
Helmhotz-HeringÓ  

É y los dos ten’an raz—n.



ÀSon de igual color los cuadrados peque–os?



ÀSon de igual color los cuadrados peque–os?



ÀSon de igual color los cuadrados A y B?



ÀSon de igual color los cuadrados A y B?



[FIJI: File > Open Samples > Striped Circles]

ÀDe quŽ color son los c’rculos?



[FIJI: File > Open Samples > Striped Circles]

ÀDe quŽ color son los c’rculos?



Sistema Visual Humano: El ojo
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Sistema Visual Humano: Fotoreceptores
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[Adaptado de https://upload.wikimedia.org/wikipedia/commons/c/c0/Eyesensitivity.svg]

https://upload.wikimedia.org/wikipedia/commons/9/94/1416_Color_Sensitivity.jpg

MustaÞ, D., Engel, A. H., & Palczewski, K. (2009). Structure of cone photoreceptors. 
Progress in retinal and eye research, 28(4), 289-302.



Sistema Visual Humano: La retina
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Distribuci—n de conos y bastones en la retina

MustaÞ, D., Engel, A. H., & Palczewski, K. (2009). Structure of cone photoreceptors. 
Progress in retinal and eye research, 28(4), 289-302.



Enfocar el ojo izquierdo en la cruz, taparse el ojo derecho y colocarse a unos 
30 cm de la imagen, hasta que ÒdesapareceÓ el punto.



Representaci—n del color
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Experimentos de Wright (1928) y Guild (1931).



Representaci—n del color

¥ El color es una caracter’stica de tres dimensiones. 

¥ Muchos colores pueden representarse como la mezcla de tres Òcolores primariosÓ A, 
B y C. 

¥ Adici—n: 

¥ Principio de tricromacia (tristimulus): con tres colores primarios se pueden generar 
otros colores (para la mayor’a de las personas). 

¥ En general un espacio de representaci—n de color est‡ generalmente asociado con un 
hardware (displays, impresoras, É)
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D = waA + wbB + wcC

D + waA = wbB + wcC ! D = " waA + wbB + wcC

RGB (aditivo, luz) CMY(K) (sustractivo, pigmentos)



RGB

¥ Aditivo 

¥ Suma de tres luces sobre un papel. 

¥ Muy simple. Usado en computadoras, monitores, c‡maras, scanners, telŽfonos, É 

¥ Calibraci—n para colorimetr’a. 

¥ No es ajustado para operaciones con colores (p.e. promedio colores).
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!"#

!"#

R

G

B

YG

C

B M

W

S

R
R 75

R 50
R 25

PK

RGB Value
Point Color R G B

S Black 0.00 0.00 0.00
R Red 1.00 0.00 0.00
Y Yellow 1.00 1.00 0.00
G Green 0.00 1.00 0.00
C Cyan 0.00 1.00 1.00
B Blue 0.00 0.00 1.00
M Magenta 1.00 0.00 1.00
W White 1.00 1.00 1.00

K 50% Gray 0.50 0.50 0.50

R 75 75% Red 0.75 0.00 0.00
R 50 50% Red 0.50 0.00 0.00
R 25 25% Red 0.25 0.00 0.00

P Pink 1.00 0.50 0.50
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CMY a CMYK:



(a)

(b)
RGB

[FIJI: Plugins > Color Inspector 3D]



[FIJI: Plugins > Color Inspector 3D]



Tipos de im‡genes RGB
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3 component arrays
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Representaci—n de RGB
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#9a2069 = (9a,20,69) Hexadecimal 
(154,32,105) 

(0.6,0.12, 0.41)

[Image > Color > Color Picker] (ctrl + shift + K)



¥ Espacio de color CIE XYZ 

¥ Colores primarios imaginarios: X (red), Y (green), Z (blue). Y es la luminancia percibida. 

¥ Basado en experimentos de percepci—n visual humana (tristimulus).

CIE XYZ colores primarios imaginarios. 

C.I.E. 1931 Color Space
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x + y + z = 1



C.I.E. 1931 Color Space
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C.I.E. 1931 Color Space
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Chromaticity Diagram



C.I.E. 1931 Color Space
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Chromaticity Diagram



C.I.E. 1931 Color Space
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Chromaticity Diagram



C.I.E. 1931 Color Space
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Chromaticity Diagram



C.I.E. 1931 Color Space

22

!"#

$"!

!"!
!"! !"# $"!

CIE L! a! b!

Laser Display

Adobe RGB

CMYK

sRGB

x

y

D65



ÀDe quŽ color son?
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Tono (Hue)
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ÀDe quŽ color son?
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ÒM‡s verdeÓ

ÒMenos verdeÓ 



Saturaci—n
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ÒPurezaÓ del color; Òmezcla con blancoÓ.



ÀDe quŽ color son?
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M‡s saturado

Menos saturado



Mismo tono, diferente saturaci—n

28

100% 90% 80% 70%

60% 50% 40% 30%

20% 10% 0%



M‡s claro

ÀDe quŽ color son?

29

M‡s oscuro

Mismo tono, misma saturaci—n, ÀquŽ es diferente?

Brillo, intensidad, É



¥ RGB !  HSB, HSV, HSI 

¥ Son muy usados en edici—n gr‡! ca para la elecci—n de colores. 

¥ M‡s e! cientes que RGB/CMYK para seleccionar colores 
similares por tono y saturaci—n. 

¥ No lineal

HSV, HSI, HSB
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R

R 75

R 50

R 25

P

RGB/HSV Values

Pt. Color R G B H S V

S Black 0.00 0.00 0.00 Ñ 0.00 0.00

R Red 1.00 0.00 0.00 0 1.00 1.00

Y Yellow 1.00 1.00 0.00 1/ 6 1.00 1.00

G Green 0.00 1.00 0.00 2/ 6 1.00 1.00

C Cyan 0.00 1.00 1.00 3/ 6 1.00 1.00

B Blue 0.00 0.00 1.00 4/ 6 1.00 1.00

M Magenta 1.00 0.00 1.00 5/ 6 1.00 1.00

W White 1.00 1.00 1.00 Ñ 0.00 1.00

R 75 75% Red 0.75 0.00 0.00 0 1.00 0.75

R 50 50% Red 0.50 0.00 0.00 0 1.00 0.50

R 25 25% Red 0.25 0.00 0.00 0 1.00 0.25

P Pink 1.00 0.50 0.50 0 0.5 1.00
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H S B



(a)

(b)
HSV



Conversi—n a escala de grises

¥ Imagen con el ÒequivalenteÓ en grises o la ÒluminanciaÓ Y.  

¥ No hay una œnica forma 

¥ La m‡s simple  

¥ La percepci—n de los canales no es la misma 

¥ Promedios ponderados
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Y = R + G+ B
3

Y = wR R + wG G + wB B

wR = 0 .299, wG = 0 .587, wB = 0 .114.

wR = 0 .2125, wG = 0 .7154, wB = 0 .072.

8 bits Lab RGB LuminanceOriginal RGB R + G+ B
3



CIE L*a*b*

¥ Basado en un conjunto de colores base (imaginarios) CIE XYZ creados en 1931. 

¥ Uniformidad cercana a la percepci—n visual humana. 

¥ La distancia Euclidea entre dos colores es similar a la diferencia percibida entre 
ellos.  

¥ Independientes del dispositivo de despliegue. 

¥ Desacopla la intensidad del color  

¥ L* corresponde a la luminosidad 

¥ a* corresponde a la variaci—n de tono-saturaci—n en el eje verde-rojo, y b* en el eje azul-
amarillo.
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X W , YW , ZW son valores de referencia relacionados con el blanco en el est‡ndar CIE D65.
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Evoluci—n de la representaci—n del color

¥ Primera generaci—n: colores f’sicos 

¥ RGB, XYZ, É 

¥ Segunda generaci—n: psicovisi—n 

¥ CIE Lab, Munsell, É 

¥ Tercera generaci—n: apariencia espacial del color 

¥ CAM, Retinex, ACE, É

36

Image> Color> Retinex
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Image> Color> Retinex



Cuantizaci—n de colores
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Original (24 bits) 256 colores (8 bits)

2 colores (1 bit)8 colores (3 bits)



Pseudo-color

¥Uso de un mapa de colores para la visualizaci—n de im‡genes monocrom‡ticas. 

¥Mejor discernimiento de colores.

39



Color segmentation

¥ ÒColor Segmentation: ImageJ plugin to cluster color pixel driven by the user inputÓ 

¥ Bajar e instalar ColorSegmentation_.jar* 

¥ Abrir la imagen mandas.jpg 
¥ Con la herramienta POINTCROSS elegir los colores (A, B, C, É). Se pueden seleccionar 

m‡s de un punto por color. 

¥ Elegir Clustering Method 

¥ Elegir algoritmo: K-Means (faster one) or Hidden Markov Model (agrega restricciones 
espaciales). 

¥ Run

40

* Daniel Sage 
  EPFL Biomedical Imaging Group 
  http://bigwww.ep " .ch/sage/soft/colorsegmentation/



Textura

41



ÀQuŽ es la textura?



ÀQuŽ es la textura?

¥ Concepto alto nivel. 

¥ Suavidad, ‡spero, regularidad, patr—n repetitivo, É 

¥ No local. 

¥ No hay una medida trivial, objetiva. 

¥ An‡lisis basado en descriptores o caracter’sticas (features). 

¥ Estructural: primitivas de construcci—n de la imagen 

¥ Estad’stico: suave, granular, É 

¥ Espectral: periodicidad, potencia en el espectro.

43



Dependencia con la escala

44



Dependencia con la escala

45
Test’culos ovinos (hematoxilina-eosina) 4x



Dependencia con la escala
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Test’culos ovinos (hematoxilina-eosina) 10x



Dependencia con la escala
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Test’culos ovinos (hematoxilina-eosina) 40x



Aplicaciones

¥ Clasi! caci—n: determinar el tipo (clase) a una nueva muestra 
¥ Segmentaci—n: partir en regiones de textura similar 
¥ S’ntesis: dada una muestra, generar otras de apariencia similar 
¥ Recuperaci—n de pose y estructura: shape from texture

48
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¥ Momentos estad’sticos del histograma de intensidades. 

¥ Primeros dos momentos 

¥ Segundo momento (varianza)                   o desviaci—n est‡ndar  

¥ Medida del contraste y la suavidad de la variaci—n. 

¥ Tercer momento (skewness)       es una medida de la simetr’a del histograma 

¥ Cuarto momento (" atness) es una medida de la ÒllanuraÓ.

MŽtricas estad’sticas

p(zi )
µn (zi ) =

L ! 1!

i =0

(zi ! m)n p(zi )

m =
L ! 1!

i =0

zi p(zi )
0 1 L - 1

R = 0

R ! 1

zonas constantes

zonas mucha variaci—n.

µ0 = 1 , µ1 = 0

µ2 = ! 2(zi )!

R = 1 !
1

1 + ! 2(z)

! (z)

µ3
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¥ ÒUniformidadÓ  

¥ Entrop’a 

¥ R (normalizada)

MŽtricas estad’sticas

U(z) =
L ! 1!

i =0

p2(zi )!

e(z) = !
L ! 1!

i =0

p(zi ) log2 p(zi )
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1

1 + ! 2(z)



MŽtricas estad’sticas
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Texture Mean deviation R (normalized) moment Uniformity Entropy

Smooth 82.64 11.79 0.002 0.026 5.434
Coarse 143.56 74.63 0.079 0.005 7.783
Regular 99.72 33.73 0.017 0.750 0.013 6.674

- 0.151
- 0.105
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MŽtricas estad’sticas

¥ Los histogramas no tiene informaci—n de la posici—n de las intensidades, que es un 
aspecto clave para la textura. 

¥ Matriz de co-ocurrencia

52
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MŽtricas estad’sticas

53

DescriptorNormalized
Co-occurrence Max 

Matri x Probability Correlation Contrast Uniformity Homogeneity Entropy

0.00006 10838 0.00002 0.0366 15.75
0.01500 0.9650 570 0.01230 0.0824 6.43
0.06860 0.8798 1356 0.00480 0.2048 13.58G3>n3

G2>n2

- 0.0005G1>n1

1 2 3
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MŽtricas espectrales

¥ Con la TF se detectan: 

¥ Picos dominantes asociados a 
direcciones principales de textura. 

¥ Tama–o (frecuencia) de las 
repeticiones espaciales. 

¥ Eliminando (! ltrando) esas 
componentes dominantes queda la 
informaci—n no peri—dica que puede 
describirse con mŽtricas estad’sticas.

54

¥ Basadas en la Transformada de Fourier o variantes como la DCT. 

¥ Ajustada para distinguir patrones repetitivos o peri—dicos. 

¥ Patrones globales.



MŽtricas basadas en ! ltros

¥ Representan la imagen a partir de la respuesta a un conjunto de ! ltros
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Conjunto de ! ltro de Gabor 
de diferente orientaci—n y 

escala.



MŽtricas basadas en ! ltros
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Descriptores

¥ Las diferentes medidas, estad’sticas, ! ltrados (procesamiento en general) nos 
permite obtener descriptores de una ROI, objeto, imagen, eventos, trayectoria, É 

¥ Con estos descriptores es posibles aprender a diferenciar los casos de interŽs.
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Pattern Recognition / Machine Learning
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Tasks (2014-09-24)  
https://xkcd.com/1425



Pattern Recognition / Machine Learning
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Pattern Recognition / Machine Learning
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Pattern Recognition / Machine Learning
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Referencias

¥ Digital Image Processing, An Algorithm Introduction to Java. Wilhelm Burger & 
Mark J. Burge. Springer, ISBN 978-1-84628-379-6  

¥ Las trasparencias usan material del libro disponible en http://www.imagingbook.com/ 

¥ Digital Image Processing, Gonzalez & Woods.  

¥ Las trasparencias usan material del libro http://www.imageprocessingplace.com/
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