
 

Guí a para realizar el primer diseñ o coñ 
QUARTUS II  

Introducción  
 A través de esta guía aprenderás cómo hacer un diseño utilizando el programa QUARTUS II y la placa 
DE0 del curso de Diseño Lógico de la Facultad de Ingeniería de la Universidad de la República.  
 

Mediante un ejemplo sencillo veremos cómo ingresar un diseño, simularlo, asignar las señales 
deseadas a los pines adecuados del chip y finalmente programarlo.  
 

El circuito que diseñaremos consiste en un circuito combinatorio que tiene como entrada la posición 
de 4 switches y como salida el estado de 2 leds.  
 
Las salidas deberán cumplir con las siguientes ecuaciones:  
 

1. dl1=a!bc+!abc+bd  
2. dl2=ac+!b!d  

 
Siendo abcd el estado de los switches SW[3..0].  
 
Construir la tabla de verdad de estas funciones y verificar que las expresiones son mínimas.  

Antes de Comenzar...  
 

Antes de comenzar debemos instalar el software necesario para realizar nuestro primer diseño.  
 
En el curso utilizaremos Quartus II 13.1 como herramienta de diseño. En este tutorial asumiremos 

que están trabajando en una PC Windows y solo explicaremos la instalación para este sistema operativo pero 
tambien existe versión para Linux y aunque su instalación sea diferente su funcionamiento es análogo. 

  
Primero debemos descargar el instalador para Windows del siguiente enlace: 
 
http://download.altera.com/akdlm/software/acdsinst/13.1/162/ib_tar/Quartus-web-13.1.0.162-

windows.tar 
 
 

El archivo Quartus-web-13.1.0.162-windows.tar (disponible en el link anterior) ocupa 4.4 GB y 
su descarga puede llevar un rato largo. Una vez descargado, descomprimirlo. Debería contener un 
archivo llamado setup.bat y una carpeta. Correr el archivo setup.bat que abrirá un terminal indicando 
los pasos a seguir (o bien buscar en la carpeta). 
 
Cuando esté listo correrá el Wizard installer del Quartus II web edition. 
 
En el instalador recomendamos utilizar la configuración mostrada en las Figuras 1 y 2 
 

http://download.altera.com/akdlm/software/acdsinst/13.1/162/ib_tar/Quartus-web-13.1.0.162-windows.tar
http://download.altera.com/akdlm/software/acdsinst/13.1/162/ib_tar/Quartus-web-13.1.0.162-windows.tar


 

 
 

 
    

 
Es importante aclarar que las computadoras de la facultad tienen instalado este mismo software, por lo que 
pueden trabajar allí. Cabe destacar también que las computadoras de la facultad con Windows no tienen 
memoria, por lo que una vez cerrado el usuario todas las modificaciones se pierden, por lo que es necesario 
utilizar un pendrive para guardar lo realizado. 
 
 También es necesario instalar los drivers para el USB-Blaster. Para ello llevar a cabo los siguientes 
pasos: 

1. Instalar los drivers de acá: http://www.terasic.com.tw/wiki/File:Usb_blaster_q16.1.zip. 
2. Conectar la placa al PC. 
3. Ir a Panel de Control > Dispositivos e Impresoras. 
4. Debajo de “No especificados” debería estar listado el USB-Blaster. 
5. Ir a Propiedades > Hardware > Propiedades. 
6. Seleccionar “Cambiar ajustes”. 
7. Seleccionar “Actualizar”. 
8. Seleccionar “Buscar en mi computadora por el software de controlador”. 
9. Encontrar <Path a la instalación del Quartus II>\quartus\drivers. 
10. Seleccionar OK. Asegurarse que el path correcto está seleccionado y darle a Siguiente. 
11. Si salta una ventana de seguridad de Windows seleccionar la opción “Siempre confiar en el software 

de Altera Corporation” y luego Instalar. 

1-Crear un Proyecto  
 

Para este diseño vamos a crear 3 proyectos, uno para cada ecuación y uno para unir los bloques. 
Comencemos por la primera ecuación, proyecto que llamaremos dl1.  
 

Al iniciar el Quartus II se despliega un menú para crear un proyecto nuevo o abrir uno existente, allí 
elegiremos la opción Create a New Project (New Project Wizard). También podemos acceder a esta opción a 
través de File>New Project Wizard.  
 
A continuación llenaremos los recuadros de la siguiente manera:  
 

Figura 1 

Figura 2 

http://www.terasic.com.tw/wiki/File:Usb_blaster_q16.1.zip


 

1. Elegimos el directorio de trabajo (c:\directorio_de_trabajo\tutorial\dl1), el nombre del proyecto 
(dl1) y el nombre del top level entity de este proyecto (dl1). Ver Figura 3. 

 
IMPORTANTE: El directorio de trabajo seleccionado, y todas las carpetas que se vayan a utilizar, no pueden 
contener ni espacios ni caracteres especiales, dado que esto da error en el Quartus II. Por ejemplo pueden 
utilizar facultad\sistemas_digitales\dislog como directorio_de_trabajo, y ya les queda para cuando cursen 
Introducción a los Microprocesadores más adelante. 
 

2. En el siguiente recuadro nos consulta si vamos a agregar algún archivo de diseño a nuestro 
proyecto, en este caso no vamos a agregar ninguno así que solo presionamos Next. Ver Figura 4. 

 
3. Seleccionamos el chip que vamos a utilizar. En la sección Device family elegimos Cyclone III, y luego 

en la lista de Available devices elegimos el chip de la placa EP3C16F484C6. Ver Figura 5. 
 

4. En el siguiente recuadro no vamos a cambiar nada así que solo presionamos Next. Ver Figura 6. 
 

5. Al final vemos un resumen de las opciones elegidas. Ver Figura 7. 
 

Figura 3 Figura 4 

Figura 5 Figura 6 



 

 

 

 

 

 

 

 

 

 

 

 

2-Crear un Archivo de Diseño  
 

Luego de haber creado el proyecto vamos a comenzar con el diseño.  
 

Seleccionamos File>New... y en el menú desplegado elegimos Design files>Block Diagram/Schematic 
File. Se abrirá una ventana en la cual se podrá comenzar a ingresar el circuito en forma gráfica. Guardar este 
archivo como dl1.bdf. En este archivo dibujaremos el circuito combinatorio correspondiente a la ecuación 1.  
 

• Para ingresar una compuerta, hacer doble click en la zona de dibujo. Se abrirá una ventana que 
permite seleccionar el componente a ingresar. Teclear en el cuadro Symbol Name el tipo de 
compuerta indicando cantidad de entradas. Ejemplos: or2 (OR de 2 entradas), and4 (AND de 4 
entradas), not (inversor), etc.  

 
• Las entradas y salidas del circuito se ingresan como cualquier componente, y sus nombres son input 

y output respectivamente. Los nombres de dichas señales se pueden cambiar haciendo doble  click 
sobre su etiqueta.  

 
• Para conectar los distintos componentes hacer click en uno de los terminales de la compuerta y 

arrastrar el mouse hasta el punto que se desea conectar, al final llegaremos a un diseño similar a la 
Figura 8.  

 
• Una vez dibujado el circuito y salvado, se puede proceder a la primera compilación. Para esto solo 

tenemos que presionar en Processing > Start Compilation.  
  

• En caso de que el Quartus reporte algún error este debe ser corregido. Una vez que se obtenga una 
compilación libre de errores vamos a crear un símbolo de nuestro diseño para utilizar en el proyecto 
final (este paso solo lo hacemos para los diseños de las ecuaciones 1 y 2). Para esto solo debemos 
hacer doble click en el archivo .bdf y luego presionar en File>Create/Update>Create Symbol Files for 
Current File. Esto nos crea un archivo .bsf (Block Symbol File) en la carpeta que estamos trabajando . 

 
 
 

Figura 7 



 

 
 
 
 
 
 
 
 
 
 
 

3-Simulación  
 

Ahora estamos en condiciones de realizar una simulación del primer bloque que hemos diseñado. 
Primero debemos seleccionar File>New... y en el menú desplegado elegimos Verification/Debugging 
Files>University Program VWF. Se abrirá el editor de formas de onda en el cual se pueden dibujar las entradas 
para la simulación. Dos valores importantes para fijar inicialmente son el tamaño de la grilla (Edit>Grid size...) 
y el tiempo total de simulación (Edit>End time...). Vamos a utilizar los siguientes valores: Grid size en 100 ns 
y End time en 1.6  µs.  
 

Para elegir las señales que veremos en nuestra simulación hacer doble click abajo de la columna de 
Name con lo cual se desplegará un menú donde presionaremos el botón Node Finder.... Una vez dentro del 
Node Finder verifiquemos que en la ventana Filter este seleccionado Pins: all y si no lo seteamos de esta 
forma (quizás para otros proyectos es útil usar algún filtro). Ahora presionamos el botón List, con lo cual se 
desplegará una lista de todos los nodos del diseño. Solo resta hacer doble click sobre las señales que 
queremos ver en la simulación (en este caso todas) para ponerlas dentro de la lista de Selected Nodes y 
presionar Ok. Ver Figura 9.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Las formas de onda se pueden dibujar con ayuda de las herramientas que aparecen sobre la parte 
superior de la pantalla (permiten sobreescribir con 0, 1, X o Z la zona seleccionada en el diagrama de tiempo, 
además de ingresar relojes, contadores, etc.) Algo útil es agrupar señales y verlas como un número en alguna 

Figura 8 

Figura 9 



 

base adecuada. Por ejemplo, en este caso se pueden agrupar las señales abcd. Primero se deben ordenar de 
forma que la señal a sea la que está en la parte superior y la señal d en la inferior. Luego se deben seleccionar 
todas las señales, presionar el botón derecho sobre la selección y hacer click sobre Grouping>Group, darle 
un nombre al grupo y seleccionar la base en la que se desea mostrar el número que forman las señales. En 
las herramientas existe la opción de generar un contador binario que puede ser útil para generar todas las 
entradas posibles al circuito (el contador es el botón que tiene una C en la barra de herramientas).  
 
 Habiendo dibujado las formas de onda deseadas guardamos el archivo y primero vamos a realizar 
una simulación Funcional en donde no aparecen los retardos de los componentes pero así podemos verificar 
la lógica de nuestro diseño (no siempre es necesario hacer este estudio, en varias ocasiones se puede pasar 
directo a la simulación con retardos). Para esto debemos presionar en Simulation>Run Functional Simulation. 
Se abrirá una nueva ventana que muestra que se está haciendo la simulación, y una vez terminada se abrirá 
una tercer ventana con las señales de entrada y la salida generadas como en la Figura 10. 
 
 

 
 
 
 
 
 
 

 
 
 
 
 
 

Para realizar una simulación teniendo en cuenta los retardos de los componentes se debe correr 
Simulation>Run Timing Simulation.  

  Repetir los pasos 1, 2 y 3 para la ecuación 2 con las siguientes diferencias:  
 
  Paso 1.1: 

 Elegimos el directorio de trabajo (c:\directorio_de_trabajo\tutorial\dl2), el nombre del proyecto 
(dl2) y el nombre del top level entity de este proyecto (dl2). 
 
  Paso 2:  

Guardar el archivo de diseño como dl2.bdf  
 
El diagrama de bloques de esta ecuación nos quedará algo similar a la Figura 11. 
  

 
Figura 11 

Figura 10 



 

 

Ahora repetir los pasos 1, 2 y 3 para el proyecto que une los diseños 1 y 2, con las 

siguientes diferencias:  
 
Paso 1.1: 

 Elegimos el directorio de trabajo (c:\directorio_de_trabajo\tutorial), el nombre del proyecto 
(tutorial) y el nombre del top level entity de este proyecto (tutorial) . 
 
Paso 1.2: 

 Aquí debemos agregar los archivos que ya hemos diseñado, buscar con el explorador dentro de las 
carpetas c:\directorio_de_trabajo\tutorial\dl1 y c:\directorio_de_trabajo\tutorial\dl2 los archivos dl1.bdf y 
dl2.bdf respectivamente y luego presionar Add. Ver Figura 12.  
 

 
Figura 12 

 Paso 2:  
Para el diseño final vamos a utilizar los símbolos que hemos creado previamente, para ello hacemos 

doble click en la zona de dibujo y en la ventana de Name: buscar con el explorador en las carpetas 
c:\directorio_de_trabajo\tutorial\dl1 y c:\directorio_de_trabajo\tutorial\dl2 los archivos dl1.bsf y dl2.bsf 
respectivamente. Guardar el archivo de diseño como tutorial.bdf y en la ventana de Project Navigator en la 
pestaña de Files presionar el botón derecho sobre el archivo tutorial y elegir en el menú desplegado Set as 
Top-Level Entity.  
 
El diagrama de bloques nos quedará algo similar a la Figura 13.  

 

Figura 13 



 

En la Figura se puede ver que se ha insertado un bus. Notar que el nombre de la entrada es SW[3..0]. 
Esto le dice al compilador que es una entrada de 4 bits. Para conectarse a un pin del bus se debe primero 
dibujar un trozo de cable, luego apretar el botón derecho sobre ese trozo, seleccionar Properties y escribir el 
nombre especificando entre paréntesis rectos a que número corresponde (ejemplo: SW[0]).  

IMPORTANTE: Sugerencias para el manejo de señales vectoriales (buses) 
 

A la hora de realizar esquemáticos en el Quartus que involucren señales vectoriales, es de utilidad 
tener en cuenta los siguientes ejemplos. 

 
Si se conecta un bus a una compuerta, el Quartus lo interpreta como una operación vectorial 

generando una compuerta por cada línea del bus, como se muestra en la siguiente figura, en la que 
ambos circuitos son equivalentes: 

 

 
Figura 14 

 El Quartus permite también conectar un bus y una línea simple (escalar) a una misma compuerta, 
como se ve en la figura 15. En el caso del ejemplo se generan tres compuertas con el escalar (señal b) 
conectado a las tres compuertas. 

Figura 15 

También es posible asignar nombres a diversas señales y definir las conexiones a un bus listando los nombres 
de las señales individuales separados con comas, como se muestra en el siguiente ejemplo. 

 
Figura 16 
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4-Asignar Pines  
 

Luego de los pasos 1, 2 y 3 del proyecto tutorial, siendo este el que vamos a programar en la placa, vamos 
a continuar asignando los pines de entrada y salida.  

4.1-Pines sin usar. 
Para evitar conflictos con elementos no utilizados en la placa se debe indicar al Quartus II que todos los 

pines no utilizados se configuren como entradas. 
Para eso seleccionar el menú "Assignments>Device". Hacer click en el boton "Device and Pin Options" 

(ver fig. 17), seleccionar la solapa "Unused Pins" y asegurarse que para "Reserve all unused pins" esté 
seleccionada la opción "As input tri-stated with weak pull-up" (fig. 18) 

 

Figura 17 

 



 

Figura 18 

 



 

4.2-Pines del diseño 
 

Las tablas que indican qué pines se corresponden con qué elementos de las placas se encuentran en el 
DE0 User Manual . 

 

 
Tabla 1 

 

 
Tabla 2 

Como entradas vamos a utilizar los switches 0, 1, 2 y 3 y como salida los LEDs 0 y 1. Ver Tablas 1 y 2.  
 

https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=&ved=2ahUKEwi9rtvHx7zrAhXMI7kGHTk4As8QFjAAegQIAxAB&url=https%3A%2F%2Feva.fing.edu.uy%2Fpluginfile.php%2F62247%2Fmod_folder%2Fcontent%2F0%2FDE0%2FDE0_User_manual_v1.1.pdf%3Fforcedownload%3D1&usg=AOvVaw3wxw62vGizZkgkZf24zf8F


 

Para comenzar con la asignación de pines debemos presionar en Assignments>Pin Planner. Luego en 
la columna Location indicamos que pines vamos a utilizar, por ejemplo para el LED 0 basta con escribir J1 y 
presionar Enter. Ver Figura 19.  

 

 
Figura 19 

Finalizada la asignación cerrando la ventana del pin planner(se guarda automáticamente), volver a compilar 
el proyecto y verificar la asignación de pines en la pestaña carpeta Fitter>Resource Section>Input Pins y 
Compilation Report>Fitter>Resource Section>Output Pins. Ver Figura 20. 
 

 
Figura 20 



 

5-Programar la Placa  
 

Antes de programar recordar que si tuvimos problemas al instalar el USB-Blaster debemos reiniciar la 
computadora, presionar F8 cuando está booteando la máquina y elegir la opción que nos permite usar 
controladores no firmados.  
 

1- Conectar el cable de alimentación a la placa en el conector J7 y a una toma de corriente.  
 

2- Conectar el cable USB a la computadora y al puerto USB-Blaster (J8) de la placa.  
 

3- Verificar que el switch 11 se encuentre en la posición de run y encender la placa presionando el botón 
rojo de ON/OFF (SW 10).  

 
4- Abrir el programador de Quartus II presionando en Tools>Programmer.  

 
5- Hacer click en Hardware Setup...  

 
6- Elegir de la lista de Available hardware items: USB-Blaster [USB-0].  

 
7- Ya nos debería aparecer el archivo tutorial.sof, en caso de que no sea así presionar en Add File... y 

seleccionarlo.  
 

8- Presionar Start... y la programación comenzará. Ver Figura 21.  
 
 

 
Figura 21 

6-Verificar el Diseño 
 

Una vez programada la placa lo único que nos queda por hacer es verificar que nuestro diseño es 
correcto, para esto darle distintas entradas al sistema variando las posiciones de los switches SW[3..0] y 
verificar que la salida es la esperada visualizando el estado de los leds LEDG0 y LEDG1 (dado que los leds 
son activos por alto, si el led está encendido tenemos un 1 en la salida y si está apagado un 0). 

 


