
ImageJ/FIJI: “Amasijando los pixeles”



Software
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IDL



• Una aplicación de software (open source) para público general 

• Una biblioteca de software 

• Una colección de plugins y servicios 

• “Write once, run anywhere” rutinas de procesamiento de imágenes

¿Qué es ImageJ?
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imagej.net
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http://imagej.net


FIJI: Fiji Is Just ImageJ
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FIJI
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Barra de menuBarra de herramientas

Barra de estado Barra de progreso

Barra de 
búsqueda 

(Control+L)



FIJI
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Operaciones 
básicas con 
archivos; se 

entiende fácil.

Operaciones de 
edición y dibujo; 

configuración 
global.

Conversión y 
modificación de 

imágenes, 
incluyendo 

transformaciones 
geométricas.

Procesamiento, 
incluyendo 

operaciones de 
pixel, filtros y 
operaciones 
aritméticas.

Medidas 
estadísticas, 

perfiles, 
histogramas, y 
operaciones de 

análisis de 
imágenes.

Comandos para 
crear, editar y 

manejar add-on. 
Incluye los Macros, 
Scripts y Plugins 

instalados.

Selección y 
manejo de 
ventanas.

Selección 
rectangular.

Selección oval, 
elíptica y brush.

Selección 
polígono.

Selección a 
mano 
alzada.

Línea recta, 
segmentos, mano 
alzada y flechas.

Medida de 
ángulos.

Puntos 
simples y 
múltiples.

“Varita mágica”
Texto

Zoom Scroll

Elección de 
colores.

Ayuda y update.

Doble click o botón derecho sobre 
los íconos permite acceder a 

configuración o variaciones de la 
herramienta.



Abrir imágenes de prueba
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2D monocromático

2D RGB

5D stack (x,y,z,c,t)

3 canales monocromáticos*

4D stack (x,y,z,c)*



Información de la imagen
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Image > Show Info (Control + I)

Metadatos 
Image > Properties 

(Control + Shift + P)

[FIJI]



Información de la imagen
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Image > Color > Channel Tools  
(Shift + Z)

[FIJI]



Información de la imagen
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En µm.



Ajuste de la imagen
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Operaciones (transformaciones) 
a nivel de pixel.



Ajuste de la imagen
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[FIJI]

Auto: define valores automáticamente. 
Set: permite definir valores sin usar las barras de desplazamiento. 

Reset: vuelve los valores a los predefinidos. 
Apply: aplica la transformación modificando los datos en la imagen.



Umbralización
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Image > Adjust > Threshold 
(Shift + T)

Image > Adjust > Auto Threshold



Histogramas
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Volvemos en un rato…



Macros y Plugins
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Macros y Plugins
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Instalación de plugins y actualización

• Instalación: 

• “Drag and drop” 

• Copiar a la carpeta FIJI/plugins 

• Seleccionar/agregar en el “Manager update site” 
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Histogramas



Histogramas

• El histograma es una conteo de los posibles valores que toma una señal (imagen).
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FIJI: Analyze > Histogram

I(u, v) h(i) = cardinal{(u, v)|I(u, v) = i}

h(i) = cardinal{(u, v)|I(u, v) = i} para todos los 0  i  K
3.2 Interpreting Histograms 39
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Figure 3.3 Histogram vector for an image with K = 16 possible intensity values. The
indices of the vector element i = 0 . . . 15 represent intensity values. The value of 10 at index
2 means that the image contains 10 pixels of intensity value 2 .

Figure 3.4 Three very different images with identical histograms.

main function of a histogram is to provide statistical information, (e.g., the
distribution of intensity values) in a compact form. Is it possible to reconstruct
an image using only its histogram? That is, can a histogram be somehow “in-
verted”? Given the loss of spatial information, in all but the most trivial cases,
the answer is no. As an example, consider the wide variety of images you could
construct using the same number of pixels of a specific value. These images
would appear different but have exactly the same histogram (Fig. 3.4).

3.2 Interpreting Histograms
A histogram depicts problems that originate during image acquisition, such as
those involving contrast and dynamic range, as well as artifacts resulting from
image-processing steps that were applied to the image. Histograms are often
used to determine if an image is making effective use of its intensity range
(Fig. 3.5) by examining the size and uniformity of the histogram’s distribution.

[Burguer & Burge]



Histogramas
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40 3. Histograms

alow ahigh

Contrast Range

linear logarithmic

Figure 3.5 The effective intensity range. The graph depicts how often a pixel value occurs
linearly (black bars) and logarithmically (gray bars). The logarithmic form makes even
relatively low occurrences, which can be very important in the image, readily apparent.

3.2.1 Image Acquisition

Exposure

Histograms make classic exposure problems readily apparent. As an example, a
histogram where a large span of the intensity range at one end is largely unused
while the other end is crowded with high-value peaks (Fig. 3.6) is representative
of an improperly exposed image.

(a) (b) (c)

Figure 3.6 Exposure errors are readily apparent in histograms. Underexposed (a), properly
exposed (b), and overexposed (c) photographs.



Histogramas

• Información global
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3.2 Interpreting Histograms 39
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Figure 3.3 Histogram vector for an image with K = 16 possible intensity values. The
indices of the vector element i = 0 . . . 15 represent intensity values. The value of 10 at index
2 means that the image contains 10 pixels of intensity value 2 .

Figure 3.4 Three very different images with identical histograms.

main function of a histogram is to provide statistical information, (e.g., the
distribution of intensity values) in a compact form. Is it possible to reconstruct
an image using only its histogram? That is, can a histogram be somehow “in-
verted”? Given the loss of spatial information, in all but the most trivial cases,
the answer is no. As an example, consider the wide variety of images you could
construct using the same number of pixels of a specific value. These images
would appear different but have exactly the same histogram (Fig. 3.4).

3.2 Interpreting Histograms
A histogram depicts problems that originate during image acquisition, such as
those involving contrast and dynamic range, as well as artifacts resulting from
image-processing steps that were applied to the image. Histograms are often
used to determine if an image is making effective use of its intensity range
(Fig. 3.5) by examining the size and uniformity of the histogram’s distribution.



Histogramas

• Exposición
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40 3. Histograms

alow ahigh

Contrast Range

linear logarithmic

Figure 3.5 The effective intensity range. The graph depicts how often a pixel value occurs
linearly (black bars) and logarithmically (gray bars). The logarithmic form makes even
relatively low occurrences, which can be very important in the image, readily apparent.

3.2.1 Image Acquisition

Exposure

Histograms make classic exposure problems readily apparent. As an example, a
histogram where a large span of the intensity range at one end is largely unused
while the other end is crowded with high-value peaks (Fig. 3.6) is representative
of an improperly exposed image.

(a) (b) (c)

Figure 3.6 Exposure errors are readily apparent in histograms. Underexposed (a), properly
exposed (b), and overexposed (c) photographs.

Sub-exposición Sobre-exposición



Histogramas

• Rango dinámico
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3.2 Interpreting Histograms 41

(a) (b) (c)

Figure 3.7 How changes in contrast affect a histogram: low contrast (a), normal con-
trast (b), high contrast (c).

Contrast

Contrast is understood as the range of intensity values effectively used within a
given image, that is the difference between the image’s maximum and minimum
pixel values. A full-contrast image makes effective use of the entire range
of available intensity values from a = amin . . . amax = 0 . . .K − 1 (black to
white). Using this definition, image contrast can be easily read directly from
the histogram. Figure 3.7 illustrates how varying the contrast of an image
affects its histogram.

Dynamic range

The dynamic range of an image is, in principle, understood as the number of
distinct pixel values in an image. In the ideal case, the dynamic range encom-
passes all K usable pixel values, in which case the value range is completely
utilized. When an image has an available range of contrast a = alow . . . ahigh,
with

amin < alow and ahigh < amax,

then the maximum possible dynamic range is achieved when all the intensity
values lying in this range are utilized (i. e., appear in the image; Fig. 3.8).

While the contrast of an image can be increased by transforming its existing
values so that they utilize more of the underlying value range available, the dy-



Histogramas

• Cuantización de intensidades
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42 3. Histograms

(a) (b) (c)

Figure 3.8 How changes in dynamic range affect a histogram: high dynamic range (a),
low dynamic range with 64 intensity values (b), extremely low dynamic range with only 6
intensity values (c).

namic range of an image can only be increased by introducing artificial (that is,
not originating with the image sensor) values using methods such as interpola-
tion (see Vol. 2 [6, Sec. 10.3]). An image with a high dynamic range is desirable
because it will suffer less image-quality degradation during image processing
and compression. Since it is not possible to increase dynamic range after im-
age acquisition in a practical way, professional cameras and scanners work at
depths of more than 8 bits, often 12–14 bits per channel, in order to provide
high dynamic range at the acquisition stage. While most output devices, such
as monitors and printers, are unable to actually reproduce more than 256 dif-
ferent shades, a high dynamic range is always beneficial for subsequent image
processing or archiving.

3.2.2 Image Defects

Histograms can be used to detect a wide range of image defects that originate
either during image acquisition or as the result of later image processing. Since
histograms always depend on the visual characteristics of the scene captured
in the image, no single “ideal” histogram exists. While a given histogram may
be optimal for a specific scene, it may be entirely unacceptable for another.
As an example, the ideal histogram for an astronomical image would likely be
very different from that of a good landscape or portrait photo. Nevertheless,

64 intensidades 6 intensidades



Histograma acumulado
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3.7 Exercises 53

i

i

h(i)

0

0

255

255

H(i)

Figure 3.13 The ordinary histogram h(i) and its associated cumulative histogram H(i).

the original image’s histogram values and then compute the cumulative
histogram “in place” according to Eqn. (3.6). Create a new (blank) image
of appropriate size (e. g., 256× 150) and draw the scaled histogram data as
black vertical bars such that the maximum entry spans the full height of
the image. Program 3.3 shows how this plugin could be set up and how a
new image is created and displayed.

Exercise 3.3
Develop a technique for nonlinear binning that uses a table of interval limits
aj (Eqn. (3.2)).

Exercise 3.4
Develop an ImageJ plugin that uses the Java methods Math.random() or
Random.nextInt(int n) to create an image with random pixel values that
are uniformly distributed in the range [0, 255]. Analyze the image’s his-
togram to determine how equally distributed the pixel values truly are.

Exercise 3.5
Develop an ImageJ plugin that creates a random image with a Gaussian
(normal) distribution with mean value µ = 128 and standard deviation
σ = 50. Use the standard Java method double Random.nextGaussian()
to produce normally-distributed random numbers (with µ = 0 and σ = 1)
and scale them appropriately to pixel values. Analyze the resulting image
histogram to see if it shows a Gaussian distribution too.

H(i) =
iX

j=0

h(k) para todos los 0  i  K

H(i) =

⇢
h(0) para i = 0
H(i� 1) + h(i) para 0 < i  K



Ecualización de histograma
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(Process > Enhance Contrast…)



Ecualización de histograma
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Operaciones de pixeles



Operaciones de pixeles
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10 1. Digital Images

M columns

N
ro

w
s

0

0 u

v

M−1

N−1

I(u, v)

Figure 1.6 Image coordinates. In digital image processing, it is common to use a coordinate
system where the origin (u = 0 , v = 0) lies in the upper left corner. The coordinates u, v
represent the columns and the rows of the image, respectively. For an image with dimensions
M × N , the maximum column number is umax = M −1 and the maximum row number is
vmax = N−1 .

zero for practical reasons, since in Java array indexing also begins at zero.

1.2.6 Pixel Values
The information within an image element depends on the data type used to
represent it. Pixel values are practically always binary words of length k so
that a pixel can represent any of 2k different values. The value k is called
the bit depth (or just “depth”) of the image. The exact bit-level layout of an
individual pixel depends on the kind of image; for example, binary, grayscale,
or RGB color. The properties of some common image types are summarized
below (also see Table 1.1).

Grayscale images (intensity images)

The image data in a grayscale image consist of a single channel that represents
the intensity, brightness, or density of the image. In most cases, only positive
values make sense, as the numbers represent the intensity of light energy or
density of film and thus cannot be negative, so typically whole integers in the
range of [0 . . . 2k−1] are used. For example, a typical grayscale image uses k = 8
bits (1 byte) per pixel and intensity values in the range of [0 . . . 255], where
the value 0 represents the minimum brightness (black) and 255 the maximum
brightness (white).

For many professional photography and print applications, as well as in
medicine and astronomy, 8 bits per pixel is not sufficient. Image depths of 12,

57 75 143 137 75 150 175 159 
59 68 98 105 69 142 179 167 
83 70 82 75 68 149 178 168 
104 85 74 58 86 162 176 165 
89 86 69 64 122 173 173 167 
81 68 71 110 160 178 172 165 
74 76 114 157 180 182 177 167 
99 122 156 182 181 177 172 166 

Valores de los pixeles.



Operaciones de pixeles

• Modificaciones del valor de un pixel 

• No hay modificaciones de tamaño, geometría o estructura 

• El nuevo valor de un pixel depende solamente del valor anterior en esa misma 
posición mediante una función 

• La función puede ser independiente de la posición (homogénea) o depender de la 
posición (no homogénea) 

• Si el resultado depende de más de una posición será el filtrado de la imagen.
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I 0(u, v) = f
�
I(u, v)

�

I 0(u, v) = g
�
I(u, v), u, v

�



Operaciones de pixeles

• Operaciones globales (homogéneas) 
• modificar brillo y contraste 

• aplicar transformaciones arbitrarias mediante curvas 

• cuantificación (“posterizing”) 

• umbralización global 

• corrección de gamma 

• transformaciones de color 

• Operaciones locales (no homogéneas) 
• cambio contraste o brillo local 

• umbralización (umbral adaptivo)
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Práctico
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https://eva.fing.edu.uy/course/view.php?name=timagieee



Práctico
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https://eva.fing.edu.uy/course/view.php?name=timagieee

• Configurar el proxy de FIng para acceder a internet  
• [Edit > Options > Proxy Settings…] 

• Proxy server: httpproxy.fing.edu.uy 

• Port: 3128


