Guia para realizar el primer disefio con
QUARTUS II

Introduccion

A través de esta guia aprenderas cdmo hacer un disefio utilizando el programa QUARTUS Il y la placa
DEO del curso de Diseio Logico de la Facultad de Ingenieria de la Universidad de la Republica.

Mediante un ejemplo sencillo veremos cémo ingresar un disefio, simularlo, asignar las sefiales
deseadas a los pines adecuados del chip y finalmente programarlo.

El circuito que disefnaremos consiste en un circuito combinatorio que tiene como entrada la posicidn
de 4 switches y como salida el estado de 2 leds.

Las salidas deberan cumplir con las siguientes ecuaciones:

1. dli=albc+labc+bd
2. dl2=ac+!b!d

Siendo abcd el estado de los switches SW|3..0].

Construir la tabla de verdad de estas funciones y verificar que las expresiones son minimas.

Antes de Comenzar...

Antes de comenzar debemos instalar el software necesario para realizar nuestro primer disefio.

En el curso utilizaremos Quartus Il 13.1 como herramienta de disefo. En este tutorial asumiremos
gue estdn trabajando en una PC Windows y solo explicaremos la instalacion para este sistema operativo pero
tambien existe version para Linux y aunque su instalacion sea diferente su funcionamiento es andlogo.

Primero debemos descargar el instalador para Windows del siguiente enlace:

http://download.altera.com/akdlm/software/acdsinst/13.1/162/ib tar/Quartus-web-13.1.0.162-
windows.tar

El archivo Quartus-web-13.1.0.162-windows.tar (disponible en el link anterior) ocupa 4.4 GB y
su descarga puede llevar un rato largo. Una vez descargado, descomprimirlo. Deberia contener un
archivo llamado setup.bat y una carpeta. Correr el archivo setup.bat que abrira un terminal indicando
los pasos a seguir (0 bien buscar en la carpeta).

Cuando esté listo correra el Wizard installer del Quartus Il web edition.

En el instalador recomendamos utilizar la configuracién mostrada en las Figuras 1y 2


http://download.altera.com/akdlm/software/acdsinst/13.1/162/ib_tar/Quartus-web-13.1.0.162-windows.tar
http://download.altera.com/akdlm/software/acdsinst/13.1/162/ib_tar/Quartus-web-13.1.0.162-windows.tar

€ Installing Quartus Il Web Edition (Free) 12.1.0.162 — [} x

Installation directory Mm
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Please spedify the directory where Quartus II Web Edition (Free) 13.1.0. 162 will be installed

Installation directory |C:\,a|hera\13. 14] | 6

Figura 1
€ Installing Quartus Il Web Edition (Free) 13.1.0.162 — O X
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Select Components m
®

Select the components you want to install

= Quartus II Web Edition (Free) Installs MAX II, MAX V device support.
Quartus II Software 64-bit support (1024MB)
Quartus II Help (618.3MB)
= Devices
[] Arria 11 (482.0MB)
Cydone III/IV (592.0MB)
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W MAXIINV (7.7MB)
ModelSim-Altera Starter Edition (Free) (3347.9MB)
[[] ModelSim-Altera Edition (3347.9MB)

Figura 2

Es importante aclarar que las computadoras de la facultad tienen instalado este mismo software, por lo que
pueden trabajar alli. Cabe destacar también que las computadoras de la facultad con Windows no tienen
memoria, por lo que una vez cerrado el usuario todas las modificaciones se pierden, por lo que es necesario
utilizar un pendrive para guardar lo realizado.

También es necesario instalar los drivers para el USB-Blaster. Para ello llevar a cabo los siguientes
pasos:
1. Instalar los drivers de aca: http://www.terasic.com.tw/wiki/File:Usb blaster q16.1.zip.

2. Conectar la placa al PC.

3. Ir a Panel de Control > Dispositivos e Impresoras.

4. Debajo de “No especificados” deberia estar listado el USB-Blaster.

5. Ira Propiedades > Hardware > Propiedades.

6. Seleccionar “Cambiar ajustes”.

7. Seleccionar “Actualizar”.

8. Seleccionar “Buscar en mi computadora por el software de controlador”.

9. Encontrar <Path a la instalacién del Quartus II>\quartus\drivers.

10. Seleccionar OK. Asegurarse que el path correcto esta seleccionado y darle a Siguiente.

11. Si salta una ventana de seguridad de Windows seleccionar la opcidn “Siempre confiar en el software

de Altera Corporation” y luego Instalar.

1-Crear un Proyecto

Para este disefio vamos a crear 3 proyectos, uno para cada ecuacién y uno para unir los bloques.
Comencemos por la primera ecuacién, proyecto que llamaremos d/1.

Al iniciar el Quartus Il se despliega un menu para crear un proyecto nuevo o abrir uno existente, alli
elegiremos la opciéon Create a New Project (New Project Wizard). También podemos acceder a esta opcion a

través de File>New Project Wizard.

A continuacidn llenaremos los recuadros de la siguiente manera:


http://www.terasic.com.tw/wiki/File:Usb_blaster_q16.1.zip

1. Elegimos el directorio de trabajo (c:\directorio_de_trabajo\tutorial\d/1), el nombre del proyecto
(dl1) y el nombre del top level entity de este proyecto (d/1). Ver Figura 3.

IMPORTANTE: El directorio de trabajo seleccionado, y todas las carpetas que se vayan a utilizar, no pueden
contener ni espacios ni caracteres especiales, dado que esto da error en el Quartus Il. Por ejemplo pueden
utilizar facultad\sistemas_digitales\dislog como directorio_de_trabajo, y ya les queda para cuando cursen

Introduccidn a los Microprocesadores mas adelante.

2. En el siguiente recuadro nos consulta si vamos a agregar algun archivo de disefio a nuestro
proyecto, en este caso no vamos a agregar ninguno asi que solo presionamos Next. Ver Figura 4.

3. Seleccionamos el chip que vamos a utilizar. En la seccidn Device family elegimos Cyclone I, y luego
en la lista de Available devices elegimos el chip de la placa EP3C16F484C6. Ver Figura 5.

4. En el siguiente recuadro no vamos a cambiar nada asi que solo presionamos Next. Ver Figura 6.

5. Al final vemos un resumen de las opciones elegidas. Ver Figura 7.

€4 New Project Wizard

Directory, Name, Top-Level Entity [page 1 of 5]

What is the working directory for this project?

[C:/aitera/ 13, 19/quartustutorial G

What is the name of this project?

[air [

What is the name of the top-level design entity for this project? This name is case sensitive and must exactly match the entity name in the design fie.

a1 =

Use Existing Project Settings. .

<Back Finish cancel Help

Figura 3

&) New Project Wizard

Family & Device Settings [page 3 of 5]

Select the family and device you want to target for compilation
You can install additional device support with the Install Devices command on the Tools menu.

Device famiy Showyin ‘Available devicss st
Family: | Cyclone I ~|  Package:  |any -
Devices: [Al Fincount:  |Any -
Target device Speed grade: [ h
Name fiter:

(O Auto device selected by the Fitter

(@ Specific device selected in 'Available devices' list Show advanced devices

Available devices:

€4 New Project Wizard

Add Files [page 2 of 5]

Select the design files you want to include in the project. Click Add Al to add all design files in the project directory to the project.
Mote: you can always add design files to the project ater.

File name:

Name Core Voltage LEs User1/0s Memory Bits Embedded multiplier 9-bit elements PLL  ald
EPICIGEI44I7 L2V 15408 85 516096 112 4 20
EP3CI16F256C5 1.2V 15408 169 516098 112 4 20
EP3CI16F256C7 1.2V 15408 169 516098 112 4 20
EP3CI16F256C8 1.2V 15408 169 516098 112 4 20
EP3CI16F25617 1.2V 15408 169 516095 112 4 20
T e - N S e N N
EP3C16F484CT L2V 15408 347 516096 112 4 20
EPICI6F484CE L2V 15408 347 516095 112 4 20
EPICIEF484I7 L2V 15408 347 516096 112 4 20
EPICIEM164... L2V 15408 93 516096 112 4 20
< >

~

<

<Back Finish Cancel Help

Figura 5

Add
FieName Type Library Design Entry/Synthesis Tool HDL Version Add all
Remove
Up
Down
Properties
Specify the path names of any non-default libraries. |User Libraries. ..
<Back — = Help
Figura 4
@ New Project Wizard
EDA Tool Settings [page 4 of 5]
Specify the other EDA tools used with the Quartus IT software to develop your project.
EDA tools:
Tool Type Tool Name Format(s) Run Tool Automatically
;0_25\97 Entry/Synthesis | <None - | <None> Run this tool au o synthesize the current design
Simulation ModelSim-Altera = | VHDL ~ [ run gatedevel simulation automatically after compilation
Formal Verification <Mone> -
Board-Level Timing <Mone > -
Symbol <Mone> -
Signal Integrity <None> -
Boundary Scan <Mone > -
<Back = o= Help
Figura 6




&4 New Project Wizard x

Summary [page 5 of 5]
When you dick Finish, the project will be created with the following settings:

Project directory: C:falteraf13. 14fquartus/tutorial
Project name: dii

Topevel design entity: d1

Number of files added: 0

Number of user libraries added: 0

Device assignments:

Family name: Cyclone I1I

Device: EP3C16F484CE

EDA tools:
Design entry/synthesis: <None> (<None>)
Simulation: ModelSim-Altera (VHDL)
Timing analysis: 0

Operating conditions:
VCCINT voltage: 12v
Junction temperature range: 0-85 °C

<na | (NG concel | [

Figura 7

2-Crear un Archivo de Diseiio

Luego de haber creado el proyecto vamos a comenzar con el disefio.

Seleccionamos File>New... y en el menu desplegado elegimos Design files>Block Diagram/Schematic
File. Se abrird una ventana en la cual se podra comenzar a ingresar el circuito en forma gréfica. Guardar este
archivo como dl1.bdf. En este archivo dibujaremos el circuito combinatorio correspondiente a la ecuacion 1.

e Para ingresar una compuerta, hacer doble click en la zona de dibujo. Se abrird una ventana que
permite seleccionar el componente a ingresar. Teclear en el cuadro Symbol Name el tipo de
compuerta indicando cantidad de entradas. Ejemplos: or2 (OR de 2 entradas), and4 (AND de 4
entradas), not (inversor), etc.

e Las entradas y salidas del circuito se ingresan como cualquier componente, y sus nombres son input
y output respectivamente. Los nombres de dichas sefiales se pueden cambiar haciendo doble click
sobre su etiqueta.

e Para conectar los distintos componentes hacer click en uno de los terminales de la compuerta y
arrastrar el mouse hasta el punto que se desea conectar, al final llegaremos a un disefio similar a la
Figura 8.

e Una vez dibujado el circuito y salvado, se puede proceder a la primera compilacién. Para esto solo
tenemos que presionar en Processing > Start Compilation.

e En caso de que el Quartus reporte algun error este debe ser corregido. Una vez que se obtenga una
compilacién libre de errores vamos a crear un simbolo de nuestro disefio para utilizar en el proyecto
final (este paso solo lo hacemos para los disefos de las ecuaciones 1y 2). Para esto solo debemos
hacer doble click en el archivo .bdf y luego presionar en File>Create/Update>Create Symbol Files for
Current File. Esto nos crea un archivo .bsf (Block Symbol File) en la carpeta que estamos trabajando .



Figura 8

3-Simulacion

Ahora estamos en condiciones de realizar una simulacién del primer bloque que hemos disefiado.
Primero debemos seleccionar File>New... y en el menl desplegado elegimos Verification/Debugging
Files>University Program VWF. Se abrira el editor de formas de onda en el cual se pueden dibujar las entradas
para la simulacién. Dos valores importantes para fijar inicialmente son el tamafio de la grilla (Edit>Grid size...)
y el tiempo total de simulacién (Edit>End time...). Vamos a utilizar los siguientes valores: Grid size en 100 ns
y End time en 1.6 ps.

Para elegir las sefiales que veremos en nuestra simulacion hacer doble click abajo de la columna de
Name con lo cual se desplegard un menu donde presionaremos el botén Node Finder.... Una vez dentro del
Node Finder verifiguemos que en la ventana Filter este seleccionado Pins: all y si no lo seteamos de esta
forma (quizas para otros proyectos es Util usar algun filtro). Ahora presionamos el botén List, con lo cual se
desplegara una lista de todos los nodos del disefio. Solo resta hacer doble click sobre las sefiales que
gueremos ver en la simulacidn (en este caso todas) para ponerlas dentro de la lista de Selected Nodes y
presionar Ok. Ver Figura 9.

&4 Node Finder *
MNamed: |" Filter:  Pins: all -
Look in: |== List Cancel
MNodes Found: Selected Modes:
Mame Type Na?ne Type
b g Input in_ 3 Input
L Input in_ Input
m_ Input o |8 c Input
L d Input - o d Input
2L dit Output e bl Output
<
<<
Figura 9

Las formas de onda se pueden dibujar con ayuda de las herramientas que aparecen sobre la parte
superior de la pantalla (permiten sobreescribir con 0, 1, X 0 Z la zona seleccionada en el diagrama de tiempo,
ademas de ingresar relojes, contadores, etc.) Algo util es agrupar sefiales y verlas como un nimero en alguna



base adecuada. Por ejemplo, en este caso se pueden agrupar las sefiales abcd. Primero se deben ordenar de
forma que la sefial a sea la que esta en la parte superior y la seial d en la inferior. Luego se deben seleccionar
todas las sefiales, presionar el botdn derecho sobre la seleccidn y hacer click sobre Grouping>Group, darle
un nombre al grupo y seleccionar la base en la que se desea mostrar el nimero que forman las sefales. En
las herramientas existe la opcién de generar un contador binario que puede ser Util para generar todas las
entradas posibles al circuito (el contador es el botén que tiene una C en la barra de herramientas).

Habiendo dibujado las formas de onda deseadas guardamos el archivo y primero vamos a realizar
una simulacidn Funcional en donde no aparecen los retardos de los componentes pero asi podemos verificar
la Iégica de nuestro disefio (no siempre es necesario hacer este estudio, en varias ocasiones se puede pasar
directo a la simulacién con retardos). Para esto debemos presionar en Simulation>Run Functional Simulation.
Se abrira una nueva ventana que muestra que se esta haciendo la simulacién, y una vez terminada se abrird
una tercer ventana con las seiales de entrada y la salida generadas como en la Figura 10.

€ simulation Waveform Editor - C:/altera/13.14/tutorial/dI1 - dI1 - [simulation/qsim/dI.sim.vu (Read-Only)]
Fle Edit View Simuaton Help 5
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Figura 10

Para realizar una simulacién teniendo en cuenta los retardos de los componentes se debe correr
Simulation>Run Timing Simulation.

Repetir los pasos 1, 2 y 3 para la ecuacion 2 con las siguientes diferencias:
Paso 1.1:
Elegimos el directorio de trabajo (c:\directorio_de_trabajo\tutorial\dl2), el nombre del proyecto

(dI2) y el nombre del top level entity de este proyecto (d/2).

Paso 2:
Guardar el archivo de disefio como d/2.bdf

El diagrama de bloques de esta ecuacidén nos quedara algo similar a la Figura 11.

Figura 11



Ahora repetir los pasos 1, 2 y 3 para el proyecto que une los disefios 1y 2, con las
siguientes diferencias:

Paso 1.1:

Elegimos el directorio de trabajo (c:\directorio_de_trabajo\tutorial), el nombre del proyecto
(tutorial) y el nombre del top level entity de este proyecto (tutorial) .

Paso 1.2:

Aqui debemos agregar los archivos que ya hemos disenado, buscar con el explorador dentro de las
carpetas c:\directorio_de_trabajo\tutorial\dl1 y c:\directorio_de_trabajo\tutorial\dI2 los archivos dl1.bdf y
dI2.bdf respectivamente y luego presionar Add. Ver Figura 12.

&4 New Project Wizard X

Add Files [page 2 of 5]

Select the design fles you want to include in the project Click Add Al to add al design files in the project directory to the project.
Note: you can always add design files to the project later.

File name: |

File Name Type Ubrary  Design Entry/SynthesisTool  HDL Version Add Al
tutorial/dl2.baf Elock Diagram Schematic File
tutorialidl1.baf lock DiagramSchematic File Remove

Specify the path names of any non-default lbraries. | User Libraries.

Figura 12

Paso 2:

Para el disefio final vamos a utilizar los simbolos que hemos creado previamente, para ello hacemos
doble click en la zona de dibujo y en la ventana de Name: buscar con el explorador en las carpetas
c:\directorio_de_trabajo\tutorial\dl1 y c:\directorio_de_trabajo\tutorial\dI2 los archivos dl1.bsf y dI2.bsf
respectivamente. Guardar el archivo de disefio como tutorial.bdf y en la ventana de Project Navigator en la

pestafia de Files presionar el botdn derecho sobre el archivo tutorial y elegir en el menu desplegado Set as
Top-Level Entity.

El diagrama de bloques nos quedara algo similar a la Figura 13.

Figura 13



En la Figura se puede ver que se ha insertado un bus. Notar que el nombre de la entrada es SW[3..0].
Esto le dice al compilador que es una entrada de 4 bits. Para conectarse a un pin del bus se debe primero
dibujar un trozo de cable, luego apretar el botdn derecho sobre ese trozo, seleccionar Properties y escribir el
nombre especificando entre paréntesis rectos a que nimero corresponde (ejemplo: SW[0]).

IMPORTANTE: Sugerencias para el manejo de sefales vectoriales (buses)

A la hora de realizar esquematicos en el Quartus que involucren sefales vectoriales, es de utilidad
tener en cuenta los siguientes ejemplos.

Si se conecta un bus a una compuerta, el Quartus lo interpreta como una operacion vectorial

generando una compuerta por cada linea del bus, como se muestra en la siguiente figura, en la que
ambos circuitos son equivalentes:
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Figura 14

El Quartus permite también conectar un bus y una linea simple (escalar) a una misma compuerta,
como se ve en la figura 15. En el caso del ejemplo se generan tres compuertas con el escalar (sefial b)
conectado a las tres compuertas.

~a2.0]
a[2] IAND2
"“~\ c[2]
./
. T — inst
3|<..V ol
* c[2..0] al1] [AND2
; :::[::::::)____q-------": —\ cl1] c[2..0
e _/
instl
a[0] [AND2
b -—-\\ c[0]
-/
inst2

Figura 15

También es posible asignar nombres a diversas sefiales y definir las conexiones a un bus listando los nombres
de las sefiales individuales separados con comas, como se muestra en el siguiente ejemplo.

a[3],UNO,UNO

IAND2

a[3..0] b[2..0]
o ?_H
5%2..0] inst5

CERO
—X
\CC
N/ UNO
GND v

Figura 16



4-Asignar Pines

Luego de los pasos 1, 2 y 3 del proyecto tutorial, siendo este el que vamos a programar en la placa, vamos
a continuar asignando los pines de entrada y salida.

4.1-Pines sin usar.

Para evitar conflictos con elementos no utilizados en la placa se debe indicar al Quartus Il que todos los
pines no utilizados se configuren como entradas.

Para eso seleccionar el menu "Assignments>Device". Hacer click en el boton "Device and Pin Options"
(ver fig. 17), seleccionar la solapa "Unused Pins" y asegurarse que para "Reserve all unused pins" esté
seleccionada la opcion "As input tri-stated with weak pull-up" (fig. 18)

& Device *

Select the family and device you want to target for compilation,
You can install additional device support with the Install Devices command on the Tools menu.

Device family Show in "Available devices' list
Family: |Cydone III - Package: Any -
Devices: | All Pin count: Any -
Speed grade: |Any -

Target device

Mame filter: |

() Auto device selected by the Fitter

/| Show ad d devi
(®) Specific device selected in 'Available devices' list O avanced devices

Othare mls
Ltnel =1

|Device and Pin Dpﬁnns...l

Available devices:

Name Core Voltage LEs User I/0s Memory Bits Embedded multiplier 9-bit elements -
EP3C10M164I7 1.2V 10320 107 423936 45
EP3C10U256CE 1.2V 10320 133 423936 45
EP3C10U256CT 1.2V 10320 133 423936 45
EP3C10U256C8 1.2V 10320 133 423936 46
EP3C10U25617 1.2V 10320 133 423936 46
EP3CI18E144CT7 1.2V 15408 a5 515096 112
EP3C18E144C8 1.2V 15408 a5 516096 112
EP3C16E 14417  1.2% 15408 85 516096 112
EP3C16F256C6 1.2V 15408 169 516096 112
EP3C16F256CT 1.2V 15408 169 516096 112
EP3C16F256CE 1.2V 15408 169 516096 112
EP3C16F256I7 1.2V 15408 169 516096 112
EP3C15F434C6 1.2V 15408 347 516096 112
FDYW 1AFARA™T 1 M icans a7 L= E=yl=" 1172 R
L4 >
Migration Devices... | 0 migration devices selected

& Buy Software oK Cancel Help

Figura 17



&4 Device and Pin Options - tutorial

Category:

General
Configuration
Programming Files
Unused Pins
Dual-Purpose Pins
Capacitive Loading
Board Trace Model
1/0 Timing

Voltage

Pin Placement

Error Detection CRC
CwP Settings

Partial Reconfiguration

Specify device-wide options for reserving all unused pins on the device. To reserve individual dual-
purpose configuration pins, go to the Dual-Purpose Fins tab. To reserve other pins individually, use
the Assignment Editor.

Reserve all unused pins: | As input tri-stated with weak pull-up -

Description:

Rezerves all unused pinz on the target device in one of 5 states: as inputs that are tri-stated, as
outputs that drive ground, as outputs that drive an unspecified signal, as input tri-stated with
bus-hold, or as input tri-stated with weak pull-up.

Reset

CK Cancel Help

Figura 18




4.2-Pines del diseio

Las tablas que indican qué pines se corresponden con qué elementos de las placas se encuentran en el

DEOQO User Manual .

LEDGIO0] PIN_J1 LED Green[0]
LEDGI[1] PIN_J2 LED Green[1]
LEDG[2] PIN_J3 LED Green[2]
LEDGI3] PIN_H1 LED Green[3]
LEDGI[4] PIN_F2 LED Green[4]
LEDG[5] PIN_E1 LED Green[5]
LEDGI6] PIN_C1 LED Green[6]
LEDG[7] PIN_C2 LED Green[7]
LEDGI8] PIN_B2 LED Green[8]
LEDGI9] PIN_B1 LED Green[9]

Tabla 1

SWIO] PIN_J6 Slide Switch[0]
SW[1] PIN_H5 Slide Switch[1]
SW[2] PIN_H6 Slide Switch[2]
SW3] PIN_G4 Slide Switch[3]
SW4] PIN_G5 Slide Switch[4]
SWI5] PIN_J7 Slide Switch[5]
SWI8] PIN_H7 Slide Switch[8]
SW[7] PIN_E3 Slide Switch[7]
SWi8] PIN_E4 Slide Switch[8]
SW9] PIN_D2 Slide Switch[9]

Como entradas vamos a utilizar los switches 0, 1, 2y 3y como salida los LEDs Oy 1. Ver Tablas 1 y 2.

Tabla 2



https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=&ved=2ahUKEwi9rtvHx7zrAhXMI7kGHTk4As8QFjAAegQIAxAB&url=https%3A%2F%2Feva.fing.edu.uy%2Fpluginfile.php%2F62247%2Fmod_folder%2Fcontent%2F0%2FDE0%2FDE0_User_manual_v1.1.pdf%3Fforcedownload%3D1&usg=AOvVaw3wxw62vGizZkgkZf24zf8F

Para comenzar con la asignacidn de pines debemos presionar en Assignments>Pin Planner. Luego en
la columna Location indicamos que pines vamos a utilizar, por ejemplo para el LED 0 basta con escribir J1y

presionar Enter. Ver Figura 19.

$ Pin Planner - Ci/altera/13.14/tuterial/tutorial/tutorial - tutorial - [m] X
File Edit View Processng Tools Window Help 5 @

Report iax Top View- Wire Bond

Report not available Cycione 111 - E P3C16F 43406

ki = -
yb
)
JE )
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G D COE000000,
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Vv & Early Pin A Besa008s %@R
1 Earl »80000%00 {5 0| B8]
TS “NAOBO ooooomoooooooo&
= Dint L

g | Named:| * |l | Edit 4 Filter:| Fins: all -
5 E Mode Mame Direction Location 10 Bank VREF Group Fitter Location 1/0 Standard
_ 24 LEDGO Cutput PIN_J1 1 Bl M1 PIN_R7 2.5V (default)
k= 24 LEDG1 Qutput PIN_J2 1 B1 M1 FIN_M4 2.5V (default)
gy n_ sw3] Input PIN_G4 1 B1_MD PIN_L7 2,5V (default)
»io o sz Input PIN_HS 1 B1_NO PIN_H2 2,5V (default)
= o sw[1] Input PIN_HS 1 Bi_MO PIN_14 2,5V {default)
[l n_ swio] Input PIN_15 1 B1_NO PIN_NS 2,5V {default)
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Figura 19

Finalizada la asignacién cerrando la ventana del pin planner(se guarda automaticamente), volver a compilar
el proyecto y verificar la asignacidon de pines en la pestaia carpeta Fitter>Resource Section>Input Pins y
Compilation Report>Fitter>Resource Section>Output Pins. Ver Figura 20.
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5-Programar la Placa

Antes de programar recordar que si tuvimos problemas al instalar el USB-Blaster debemos reiniciar la
computadora, presionar F8 cuando esta booteando la maquina y elegir la opcién que nos permite usar
controladores no firmados.

1- Conectar el cable de alimentacidn a la placa en el conector J7 y a una toma de corriente.

2- Conectar el cable USB a la computadora y al puerto USB-Blaster (J8) de la placa.

3- Verificar que el switch 11 se encuentre en la posicién de run y encender la placa presionando el botén
rojo de ON/OFF (SW 10).

4- Abrir el programador de Quartus Il presionando en Tools>Programmer.
5- Hacer click en Hardware Setup...
6- Elegir de la lista de Available hardware items: USB-Blaster [USB-0].

7- Ya nos deberia aparecer el archivo tutorial.sof, en caso de que no sea asi presionar en Add File... y
seleccionarlo.

8- Presionar Start... y la programacion comenzard. Ver Figura 21.

:@) Programmer - C:/altera/13.14/tutorial/tutorial ftutorial - tutorial - [Chain3.cdf]” - [m] X

Fle Edit View Processing Tools Window Help &

_:. Hardware Setup...| |USB-Blaster [USE-0] Mode: | JTAG ~ Progress: D

[] Enable real-time ISP to allow background programming (for MAX I1 and MAX V devices)

W File Device Checksum Usercode Program/
il Start Configure
e output_files/tutorial sof ~ EP3C15F434 000CTEDS 000CTEDS
4 Auto Detect
(4 Add File,
= < >

EP3C16F454

Figura 21

6-Verificar el Diseio

Una vez programada la placa lo Unico que nos queda por hacer es verificar que nuestro disefio es
correcto, para esto darle distintas entradas al sistema variando las posiciones de los switches SW[3..0] y
verificar que la salida es la esperada visualizando el estado de los leds LEDGO y LEDG1 (dado que los leds
son activos por alto, si el led esta encendido tenemos un 1 en la salida y si esta apagado un 0).



